Users are unable to create new schools
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 13:45 EDT
Investigating
We are currently investigating this issue.
Posted Oct 18, 2023 - 13:26 EDT