Between 11:00 AM and 12:05 PM ET, Teachable experienced a disruption that resulted in downstream platform instabilities and parts of the app being potentially inaccessible during this window.
This was the result of a security-related incident. Our automated protection controls engaged as designed and successfully mitigated the attack. The platform is now operating normally. Thank you for your patience, and apologies for any inconvenience caused.
Posted Dec 12, 2025 - 12:50 EST
Monitoring
We’ve confirmed that elevated traffic contributed to the earlier instability. Performance has improved, and we are actively monitoring to ensure stability is fully restored.
Posted Dec 12, 2025 - 12:34 EST
Investigating
We are experiencing intermittent platform instability resulting in degraded performance and elevated error rates. The underlying cause is not yet identified, and the team is actively investigating across multiple systems. Mitigation efforts are underway, and updates will be shared as more information becomes available.