Major Outage
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 13:11 EST
Identified
We've deployed a fix after identifying the issue that was impacting school load times and platform functionality for creators and students. Both parties should now have functionality restored, though some users may still encounter delays in the short term as we get to a complete resolution. We understand the importance of this issue—our team is on it.
Posted Mar 04, 2024 - 13:07 EST
Update
We are continuing to investigate this issue.
Posted Mar 04, 2024 - 12:46 EST
Investigating
We are experiencing large scale outages. This results in increased load times and decreased functionality across Teachable's platform. We are investigating.
Posted Mar 04, 2024 - 12:41 EST
This incident affected: teachable.com and developers.teachable.com.