Temporary Payout Delays
Incident Report for Teachable
Resolved
We can now confirm all pending payouts have been completed. Thank you for your patience and we sincerely apologize for the concern this may have caused—we very much understand the trust you put in us when it comes to your money.
Posted Jan 18, 2024 - 16:57 EST
Update
Our team is actively addressing the issue and will be incrementally processing payouts over the next 48 hours. We anticipate returning to our regular cadence by the end of the week. We apologize for any inconvenience this may have caused. Thank you for your patience and understanding.
Posted Jan 17, 2024 - 17:32 EST
Monitoring
Payout delays over the weekend are being resolved. We're actively monitoring and will update as necessary.
Posted Jan 16, 2024 - 18:04 EST
This incident affected: Accepting & Processing Payments (teachable:pay).