Our Dropbox file upload service is currently undergoing an upgrades and will be unavailable for a short period of time. As an alternative for uploading files, we recommend utilizing the options of device upload, Microsoft One Drive, and Google Drive. We will continue to provide updates as we have a more specific timeline for the service to return to normal operations.
Posted Mar 20, 2025 - 09:47 EDT
Monitoring
Due to outages with our file upload integration service, FileStack, Dropbox file uploads continue to experience intermittent failures. Currently, uploading files directly from a device, Microsoft One Drive, and Google Drive is working as expected so we’re recommending these methods at this time. We’re continuing to monitor performance and will provide an update as Dropbox file upload returns to normal operations
Posted Mar 04, 2025 - 10:34 EST
Update
We're investigating reported errors with file upload via Dropbox, Google Drive, and Microsoft One Drive. Uploading files from your own device is working as expected so please use this method for file upload at this time.
Posted Mar 03, 2025 - 16:04 EST
Investigating
We’re investigating errors with file upload via Dropbox and Google Drive, please use one of other supported methods at this time as we diagnose the potential issue
Posted Mar 03, 2025 - 15:41 EST
This incident affects: Managing your School (Course Building, Digital Downloads, Product Administration, Video Uploading).