Delay in payouts for creators leveraging Teachable's Monthly Payment Gateway
Incident Report for Teachable
Resolved
Our team has resolved the payouts for creators leveraging Teachable's Monthly Payment Gateway. Payouts originally scheduled for Friday, March 1, 2024 have been successfully transferred from Teachable to respective PayPal accounts as of 8pm EST on March 5, 2024.
Posted Mar 05, 2024 - 20:18 EST
Update
Our team continues to actively address the issue affecting timely payouts for creators leveraging Teachable's Monthly Payment Gateway. Resolving this issue and ensuring prompt payouts remains our top priority. We recognize the urgency of this matter and will provide further updates as soon as possible.
Posted Mar 05, 2024 - 11:34 EST
Identified
We've identified a delay in payouts for creators leveraging Teachable's Monthly Payment Gateway. These payouts were originally scheduled for March 1, 2024. Our team is actively working to resolve this issue and deploy a fix so creators' payouts are delivered as quickly as possible. We understand the importance of this situation and are taking it very seriously. We'll share an update as soon as possible.
Posted Mar 04, 2024 - 15:44 EST
This incident affected: Accepting & Processing Payments (Monthly Payment Gateway).