Service Update: Onboarding Restored, Monitoring in Progress

Incident Report for Teachable

Monitoring

Service Update: Onboarding Restored, Monitoring in Progress

Onboarding is back up and running. All services affected by the payment processing integration issue, including Payouts, are now fully operational.
Our team is actively monitoring to confirm stability.

Thank you for your patience throughout this incident.
Posted Sep 02, 2026 - 18:53 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2026 - 18:50 EDT

Update

Service Update: Payouts Restored, Onboarding Still Unstable

Payouts are now back up and running, pending payouts are being processed as expected.
Onboarding is still experiencing instability, and we continue working to fully resolve the issue. We'll update this page as soon as it's back to normal.
Thank you for your patience.
Posted Sep 02, 2026 - 16:42 EDT

Identified

We are currently experiencing a temporary disruption affecting Onboarding and Payouts due to an issue with our payment processing integration. Both services are currently unavailable.

Our team is actively working to resolve this and restore full functionality as quickly as possible. Any pending payouts will be processed in the next payout wave once service is restored, within the next 24h.

We are also assessing the impact on affected accounts and will follow up directly with more details as needed. We apologize for the inconvenience and appreciate your patience.
Posted Sep 02, 2026 - 11:10 EDT
This incident affects: Accepting & Processing Payments (teachable:pay).