Product Display Page & Sales Page URL Conflict

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 11:24 EDT

Monitoring

We've pushed a fix to resolve the cases we have received regarding Product Description Pages displaying incorrect product and price information. We have tested the small number of Product Description Pages previously impacted, and the issue no longer persists. We will continue to monitor in the short term.

At this time, there should be no outstanding cases of incorrect product and price displaying on Product Description Pages.
Posted Mar 31, 2025 - 11:05 EDT

Investigating

We are investigating a small number of reported incidents regarding Product Description Pages displaying incorrect product and price information. A fix will be implemented shortly - in the meantime, we recommend navigating prospective buyers to your checkout page or an alternative sales page.
Posted Mar 26, 2025 - 18:24 EDT
This incident affected: Student Experience (Checkout) and teachable.com.