Investigating blank pages on Course Curriculum pages
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 18:04 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2024 - 15:24 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 02, 2024 - 15:19 EDT
Investigating
Our engineering team is investigating the source of blank pages impacting Curriculum pages when students click into a course. Other products are unaffected.

We will provide an update as soon as there's additional information available.
Posted Jul 02, 2024 - 15:19 EDT