Delay in Student Enrollment

Incident Report for Teachable

Resolved

The fix for the recent enrollment delays has been confirmed. Enrollment times are back within normal range, and no further impact is expected.
Posted Sep 24, 2026 - 08:57 EDT

Monitoring

A fix has been deployed for the recent enrollment delays.
Note: for a new enrollment to show up in the Admin, it could take some time. We're working to improve this, and we're monitoring the system.
Posted Sep 23, 2026 - 15:59 EDT

Investigating

We are currently investigating a delay in enrollment after students complete their purchase, which may be impacting some users.
Posted Sep 22, 2026 - 11:18 EDT