Unusually High Processing Queue
Incident Report for Teachable
Resolved
The issue causing unusually high processing queue latency has been resolved. Background jobs are now processing without delay as the queue has cleared. We thank you for your patience and apologize for any inconvenience this may have caused. If you experience any further issues, please don't hesitate to reach out to our support team.
Posted Mar 27, 2024 - 21:45 EDT
Update
We are making progress and actively attempting to adjust our infrastructure to clear queues, but we still don’t have a clear ETA for resolution
Posted Mar 27, 2024 - 19:22 EDT
Monitoring
We're experiencing unusually high processing queue latency, which may lead to delays in processing background jobs. We're monitoring and response times are trending towards normal. We expect that all jobs initiated during this latency will process as the queue clears.
Posted Mar 27, 2024 - 17:40 EDT
This incident affected: Student Experience (Checkout, Content Delivery), teachable.com, and Managing your School (Product Administration, Reporting, User Management).