Incorrect fees on some transactions

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted May 19, 2025 - 10:00 EDT

Update

We've solved the root cause and have identified all impacted transactions. This impacted transactions by Pro schools from Tuesday, May 13 to Thursday, May 15. All incorrect fees are being refunded in upcoming payouts.
Posted May 16, 2025 - 08:38 EDT

Monitoring

We've identified the root cause and have applied a fix. We're monitoring to ensure that fees are being applied correctly as a result.
Posted May 15, 2025 - 14:09 EDT

Investigating

We've investigating an issue causing incorrect fees to apply to student transactions between Tuesday, May 13 and Thursday, May 15. This appears to impact schools on Pro and Legacy plans. All impacted transactions will be identified and have incorrect fees refunded.
Posted May 15, 2025 - 12:20 EDT
This incident affected: Accepting & Processing Payments (Monthly Payment Gateway, teachable:pay).