Student Experience is intermittently unavailable

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 17:31 EDT

Monitoring

We've implemented a fix for the issue impacting students' ability to view Browse Products and product details pages. We will continue to monitor the availability of these pages.
Posted Apr 03, 2025 - 17:02 EDT

Identified

We have identified an issue where some parts of the student experience are intermittently unavailable. The issue will impact students' ability to view Browse Products and product details pages.
Posted Apr 03, 2025 - 16:30 EDT