Issue with school login
Incident Report for Teachable
Resolved
The login issue for custom domain users has been successfully resolved. If you were impacted by this issue and updated your domain as a temporary workaround, you are welcome to either maintain the new one or change it back to its original. Thank you for your patience as we worked to get this resolved as quickly as possible.
Posted Feb 26, 2024 - 12:31 EST
Investigating
We are currently investigating an issue that is affecting login for schools with a custom domain
Posted Feb 26, 2024 - 09:45 EST
This incident affected: Account (Log In).