Klarna temporarily disabled
Incident Report for Teachable
Resolved
We have reinstated the Klarna payment method on Student Checkout.
Posted Dec 04, 2023 - 20:53 EST
Update
Our efforts to fix the Klarna payment issue on Student Checkout are ongoing. We appreciate your patience and will keep you informed as we make progress.
Posted Nov 13, 2023 - 17:32 EST
Identified
Klarna payment option is currently unavailable on Student Checkout. We are working to resolve an issue and will restore this payment method as soon as possible.
Posted Nov 10, 2023 - 15:47 EST
This incident affected: Accepting & Processing Payments (Klarna Europe).