Intermittent feature degradation
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 16:33 EST
Monitoring
Creators may experience intermittent issues with the uploading of files. One of our service providers is experiencing an intermittent service outage and are currently working to resolve the issue. We apologize for any inconvenience.
Posted Jan 20, 2023 - 13:02 EST
This incident affected: Managing your School (Video Uploading).