Incorrect aggregated sales data displayed
Incident Report for Teachable
Postmortem

Our team identified and addressed the technical bug responsible for the discrepancies on the Admin Dashboard. We appreciate your understanding and patience during this time.

Posted Dec 01, 2023 - 14:35 EST

Resolved
Creators experienced discrepancies on their admin dashboards, with incorrect totals and sales data.
Posted Nov 28, 2023 - 15:30 EST