We've pushed a fix and are monitoring the issue causing latency in our earnings calculations appearing within the Teachable application and a related delay in payouts for some creators leveraging Teachable's Payment Gateway. The delay would have impacted payouts that were scheduled for March 4th.
We’ve identified the root cause and are implementing a fix to resolve the latency with earnings calculations and resume normal payout cadence. We expect all outstanding payouts to be completed by March 5.
There is no impact to student-facing functionality or sales-related experiences. All sales and transactions occurring during this time period will pay out successfully once we’ve remediated this delay.
Posted Mar 04, 2025 - 15:19 EST
Investigating
We've identified an issue causing latency in our earnings calculations appearing within the Teachable application and a related delay in payouts for some creators leveraging Teachable's Payment Gateway. The delay may impact payouts that are scheduled for March 4th. Our team is working as quickly as possible on a fix.
Posted Mar 04, 2025 - 13:10 EST
This incident affected: Managing your School (Reporting).