High latency on Teachable pages
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Oct 11, 2022 - 13:22 EDT
Update
We have made some updates to address the slowness; the application is currently stable and we're continuing to monitor to ensure the system is restored to operational status
Posted Oct 11, 2022 - 12:04 EDT
Monitoring
Large scale outages amongst one or more of our service providers have resulted in increased load times and decreased functionality across Teachable's platform. Our development team is closely monitoring the situation. We will provide updates as soon as they become available.
Posted Oct 11, 2022 - 11:13 EDT
Investigating
There is high latency on Teachable pages, causing slowness to our application. We are actively investigating the issue and hope to have it resolved shortly
Posted Oct 11, 2022 - 07:11 EDT