Students unable to access purchased products
Incident Report for Teachable
Resolved
This incident has been resolved
Posted Mar 15, 2024 - 10:21 EDT
Identified
Identified - Our team has identified a technical issue preventing some students from accessing their purchased products. In these cases, creators are experiencing delayed payouts. Our team is working hard to understand the root cause and to remedy the situation as quickly as possible. We understand the impact this has on both creators and students, and are treating this as a top priority
Posted Mar 13, 2024 - 15:30 EDT
This incident affected: Student Experience (Checkout) and teachable.com.