Intermittent issues with Yahoo & Outlook email deliverability
Incident Report for Teachable
Resolved
[Resolved October 2nd] Our team has resolved deliverability issues for all transactional emails being sent to Yahoo and Microsoft-based accounts. We apologize for the inconvenience and thank you for your patience.
Posted Oct 10, 2024 - 10:36 EDT
Update
We’ve resolved deliverability issues for all transactional emails being sent to Microsoft-based accounts. Our team is now in the process of deploying a fix to resolve deliverability issues for Yahoo-based accounts. We apologize for the inconvenience and thank you for your patience.
Posted Oct 02, 2024 - 10:16 EDT
Identified
We’ve identified an issue with Teachable’s email deliverability for some Yahoo and Outlook based accounts. Our team is actively investigating ways of improving our sender reputation.
Our team is in the process of deploying a fix and expect this to be resolved shortly. We apologize for the inconvenience and thank you for your patience.
Posted Sep 30, 2024 - 16:44 EDT