Manual Enrollments Failing
Incident Report for Teachable
Resolved
Our team has resolved the issue preventing users from properly adding new manual enrollments. We thank you for your patience as our team worked as quickly as possible to resolve the situation.
Posted Oct 08, 2024 - 15:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 08, 2024 - 14:44 EDT
Identified
We’ve identified an issue preventing users from properly adding new manual enrollments to their schools. Our team is in the process of deploying a fix and expect this to be resolved shortly. We apologize for the inconvenience and thank you for your patience.
Posted Oct 08, 2024 - 14:43 EDT
This incident affected: Managing your School (User Management).