Experiencing slowdown across platform.
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 10:44 EST
Monitoring
Our team has resolved the issue and we are monitoring.
Posted Mar 05, 2024 - 22:33 EST
Identified
We've successfully identified the root causes of slower-than-usual platform load times and are actively deploying a fix. We anticipate seeing improvements by 6pm ET as we return to our usual platform functionality. Thank you for your patience.
Posted Mar 05, 2024 - 17:43 EST
Investigating
We are currently investigating.
Posted Mar 05, 2024 - 12:27 EST