Custom domain connection errors

Incident Report for Teachable

Resolved

This issue is resolved.
Posted Jul 15, 2025 - 07:24 EDT

Monitoring

We've determined the root cause of the connection errors and are currently monitoring a workflow to resolve the problem.
Posted Jul 14, 2025 - 18:26 EDT

Investigating

We're currently investigating the reason that some custom domains are showing connection errors when attempting to navigate to the associated school website.
Posted Jul 14, 2025 - 18:09 EDT