Platform Latency
Incident Report for Teachable
Resolved
We’ve successfully identified and mitigated the root cause of earlier, intermittent unavailability across the platform. All creators and their students should now be experiencing usual platform functionality. We apologize for the inconveniences this has caused and thank you for your patience.
Posted Mar 12, 2024 - 10:26 EDT
Identified
We are currently investigating intermittent outages that may result in increased load times across Teachable's platform. Our development team is actively addressing the situation. We will provide updates as soon as they become available.
Posted Mar 12, 2024 - 09:46 EDT
This incident affected: developers.teachable.com.