Monthly Payment Gateway Payouts Delay
Incident Report for Teachable
Resolved
A subset of MPG payouts originally scheduled for July 1, 2024, including relevant author and affiliate payouts, have now been successfully processed by our team and creators can expect to see funds in their PayPal account today. Thank you for your patience.
Posted Jul 03, 2024 - 14:15 EDT
Identified
Due to a brief platform outage yesterday, July 1, 2024, we've identified a delay in payouts for a subset of creators using Teachable's Monthly Payment Gateway (MPG). Our team is actively working to resolve this delay and is expecting to process these payouts ASAP. We apologize for the inconvenience and any disruption to your regular business operations—thank you for your patience.
Posted Jul 02, 2024 - 14:04 EDT
This incident affected: teachable.com.